Senin, 25 Maret 2019

How to install semanage on Fedora

  Tidak ada komentar
Looking for semanage package name 
[[email protected] ~]# yum provides semanage
Last metadata expiration check: 0:19:16 ago on Mon 25 Mar 2019 04:42:18 PM WIB.
policycoreutils-python-utils-2.7-6.fc27.x86_64 : SELinux policy core python utilities
Repo        : updates
Matched from:
Filename    : /usr/sbin/semanage

policycoreutils-python-utils-2.7-1.fc27.x86_64 : SELinux policy core python utilities
Repo        : fedora
Matched from:
Filename    : /usr/sbin/semanage

[[email protected] ~]#
Perform package installation
[[email protected] ~]# yum install policycoreutils-python-utils-2.7-1.fc27.x86_64
Last metadata expiration check: 0:19:30 ago on Mon 25 Mar 2019 04:42:18 PM WIB.
Dependencies resolved.
======================================================================================================================================
 Package                                       Arch                    Version                         Repository                Size
======================================================================================================================================
Installing:
 policycoreutils-python-utils                  x86_64                  2.7-1.fc27                      fedora                   223 k
Installing dependencies:
 audit-libs-python3                            x86_64                  2.8.3-1.fc27                    updates                   82 k
 checkpolicy                                   x86_64                  2.7-2.fc27                      updates                  330 k
 libcgroup                                     x86_64                  0.41-17.fc27                    updates                   68 k
 libsemanage-python3                           x86_64                  2.7-3.fc27                      updates                  122 k
 policycoreutils-python3                       x86_64                  2.7-1.fc27                      fedora                   1.8 M
 setools-python3                               x86_64                  4.1.1-3.fc27                    fedora                   585 k
Downgrading:
 policycoreutils                               x86_64                  2.7-1.fc27                      fedora                   705 k

Transaction Summary
======================================================================================================================================
Install    7 Packages
Downgrade  1 Package

Total download size: 3.9 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): policycoreutils-python-utils-2.7-1.fc27.x86_64.rpm                                             838 kB/s | 223 kB     00:00
(2/8): policycoreutils-2.7-1.fc27.x86_64.rpm                                                          1.5 MB/s | 705 kB     00:00
(3/8): setools-python3-4.1.1-3.fc27.x86_64.rpm                                                        1.8 MB/s | 585 kB     00:00
(4/8): audit-libs-python3-2.8.3-1.fc27.x86_64.rpm                                                     522 kB/s |  82 kB     00:00
(5/8): libsemanage-python3-2.7-3.fc27.x86_64.rpm                                                      904 kB/s | 122 kB     00:00
(6/8): libcgroup-0.41-17.fc27.x86_64.rpm                                                              1.3 MB/s |  68 kB     00:00
(7/8): checkpolicy-2.7-2.fc27.x86_64.rpm                                                              1.9 MB/s | 330 kB     00:00
(8/8): policycoreutils-python3-2.7-1.fc27.x86_64.rpm                                                  1.9 MB/s | 1.8 MB     00:00
--------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                 1.1 MB/s | 3.9 MB     00:03
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                              1/1
  Running scriptlet: libcgroup-0.41-17.fc27.x86_64                                                                                1/1
  Running scriptlet: libcgroup-0.41-17.fc27.x86_64                                                                                1/9
  Installing       : libcgroup-0.41-17.fc27.x86_64                                                                                1/9
  Running scriptlet: libcgroup-0.41-17.fc27.x86_64                                                                                1/9
  Installing       : checkpolicy-2.7-2.fc27.x86_64                                                                                2/9
  Installing       : libsemanage-python3-2.7-3.fc27.x86_64                                                                        3/9
  Installing       : audit-libs-python3-2.8.3-1.fc27.x86_64                                                                       4/9
  Installing       : setools-python3-4.1.1-3.fc27.x86_64                                                                          5/9
  Downgrading      : policycoreutils-2.7-1.fc27.x86_64                                                                            6/9
  Installing       : policycoreutils-python3-2.7-1.fc27.x86_64                                                                    7/9
  Installing       : policycoreutils-python-utils-2.7-1.fc27.x86_64                                                               8/9
  Erasing          : policycoreutils-2.7-6.fc27.x86_64                                                                            9/9
  Running scriptlet: policycoreutils-2.7-6.fc27.x86_64                                                                            9/9
Running as unit: run-r3d86f52d49be40788d7cd106e7efc471.service
Running as unit: run-r8870a02b7d7147d98c144f9d018cbd1d.service
  Verifying        : policycoreutils-2.7-1.fc27.x86_64                                                                            1/9
  Verifying        : policycoreutils-python-utils-2.7-1.fc27.x86_64                                                               2/9
  Verifying        : policycoreutils-python3-2.7-1.fc27.x86_64                                                                    3/9
  Verifying        : setools-python3-4.1.1-3.fc27.x86_64                                                                          4/9
  Verifying        : audit-libs-python3-2.8.3-1.fc27.x86_64                                                                       5/9
  Verifying        : libsemanage-python3-2.7-3.fc27.x86_64                                                                        6/9
  Verifying        : checkpolicy-2.7-2.fc27.x86_64                                                                                7/9
  Verifying        : libcgroup-0.41-17.fc27.x86_64                                                                                8/9
  Verifying        : policycoreutils-2.7-6.fc27.x86_64                                                                            9/9

Installed:
  policycoreutils-python-utils.x86_64 2.7-1.fc27  audit-libs-python3.x86_64 2.8.3-1.fc27  checkpolicy.x86_64 2.7-2.fc27
  libcgroup.x86_64 0.41-17.fc27                   libsemanage-python3.x86_64 2.7-3.fc27   policycoreutils-python3.x86_64 2.7-1.fc27
  setools-python3.x86_64 4.1.1-3.fc27

Downgraded:
  policycoreutils.x86_64 2.7-1.fc27

Complete!
[[email protected]itop ~]#

Tidak ada komentar :

Posting Komentar