Selasa, 05 Januari 2021

How to solved "Peer reports incompatible or unsupported protocol version."

  Tidak ada komentar

I got error alert "Peer reports incompatible or unsupported protocol version." when installing elasticsearch packages.

[[email protected] ~]# rpm --import https://artifacts.elastic.co/GPG-KEY-elasticsearch
curl: (35) Peer reports incompatible or unsupported protocol version.
error: https://artifacts.elastic.co/GPG-KEY-elasticsearch: import read failed(2).
[[email protected] ~]#
The sollution, update the nss, curl and libcurl 
[[email protected] ~]# yum update -y nss curl libcurl
Loaded plugins: fastestmirror
base                                                                                                       | 3.6 kB  00:00:00
extras                                                                                                     | 2.9 kB  00:00:00
updates                                                                                                    | 2.9 kB  00:00:04
Loading mirror speeds from cached hostfile
 * base: kartolo.sby.datautama.net.id
 * extras: mirror.papua.go.id
 * updates: mirror.papua.go.id
Resolving Dependencies
--> Running transaction check
---> Package curl.x86_64 0:7.29.0-19.el7 will be updated
---> Package curl.x86_64 0:7.29.0-59.el7_9.1 will be an update
---> Package libcurl.x86_64 0:7.29.0-19.el7 will be updated
---> Package libcurl.x86_64 0:7.29.0-59.el7_9.1 will be an update
--> Processing Dependency: nss-pem(x86-64) >= 1.0.3-5 for package: libcurl-7.29.0-59.el7_9.1.x86_64
--> Processing Dependency: libssh2(x86-64) >= 1.8.0 for package: libcurl-7.29.0-59.el7_9.1.x86_64
---> Package nss.x86_64 0:3.16.2.3-5.el7 will be updated
--> Processing Dependency: nss = 3.16.2.3-5.el7 for package: nss-sysinit-3.16.2.3-5.el7.x86_64
--> Processing Dependency: nss(x86-64) = 3.16.2.3-5.el7 for package: nss-tools-3.16.2.3-5.el7.x86_64
---> Package nss.x86_64 0:3.53.1-3.el7_9 will be an update
--> Processing Dependency: nss-util >= 3.53.1-1 for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: nss-softokn(x86-64) >= 3.53.1-2 for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: nspr >= 4.25.0 for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.39)(64bit) for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.38)(64bit) for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.31)(64bit) for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.24)(64bit) for package: nss-3.53.1-3.el7_9.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.21)(64bit) for package: nss-3.53.1-3.el7_9.x86_64
--> Running transaction check
---> Package libssh2.x86_64 0:1.4.3-8.el7 will be updated
---> Package libssh2.x86_64 0:1.8.0-4.el7 will be an update
---> Package nspr.x86_64 0:4.10.6-3.el7 will be updated
---> Package nspr.x86_64 0:4.25.0-2.el7_9 will be an update
---> Package nss-pem.x86_64 0:1.0.3-7.el7 will be installed
---> Package nss-softokn.x86_64 0:3.16.2.3-9.el7 will be updated
---> Package nss-softokn.x86_64 0:3.53.1-6.el7_9 will be an update
--> Processing Dependency: nss-softokn-freebl(x86-64) >= 3.53.1-6.el7_9 for package: nss-softokn-3.53.1-6.el7_9.x86_64
---> Package nss-sysinit.x86_64 0:3.16.2.3-5.el7 will be updated
---> Package nss-sysinit.x86_64 0:3.53.1-3.el7_9 will be an update
---> Package nss-tools.x86_64 0:3.16.2.3-5.el7 will be updated
---> Package nss-tools.x86_64 0:3.53.1-3.el7_9 will be an update
---> Package nss-util.x86_64 0:3.16.2.3-2.el7 will be updated
---> Package nss-util.x86_64 0:3.53.1-1.el7_9 will be an update
--> Running transaction check
---> Package nss-softokn-freebl.x86_64 0:3.16.2.3-9.el7 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.53.1-6.el7_9 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================
 Package                             Arch                    Version                               Repository                Size
==================================================================================================================================
Updating:
 curl                                x86_64                  7.29.0-59.el7_9.1                     updates                  271 k
 libcurl                             x86_64                  7.29.0-59.el7_9.1                     updates                  223 k
 nss                                 x86_64                  3.53.1-3.el7_9                        updates                  869 k
Installing for dependencies:
 nss-pem                             x86_64                  1.0.3-7.el7                           base                      74 k
Updating for dependencies:
 libssh2                             x86_64                  1.8.0-4.el7                           base                      88 k
 nspr                                x86_64                  4.25.0-2.el7_9                        updates                  127 k
 nss-softokn                         x86_64                  3.53.1-6.el7_9                        updates                  354 k
 nss-softokn-freebl                  x86_64                  3.53.1-6.el7_9                        updates                  322 k
 nss-sysinit                         x86_64                  3.53.1-3.el7_9                        updates                   65 k
 nss-tools                           x86_64                  3.53.1-3.el7_9                        updates                  535 k
 nss-util                            x86_64                  3.53.1-1.el7_9                        updates                   79 k

Transaction Summary
==================================================================================================================================
Install             ( 1 Dependent package)
Upgrade  3 Packages (+7 Dependent packages)

Total download size: 2.9 M
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/11): nspr-4.25.0-2.el7_9.x86_64.rpm                                                                     | 127 kB  00:00:00
(2/11): libssh2-1.8.0-4.el7.x86_64.rpm                                                                     |  88 kB  00:00:00
(3/11): libcurl-7.29.0-59.el7_9.1.x86_64.rpm                                                               | 223 kB  00:00:01
(4/11): nss-softokn-freebl-3.53.1-6.el7_9.x86_64.rpm                                                       | 322 kB  00:00:01
(5/11): nss-softokn-3.53.1-6.el7_9.x86_64.rpm                                                              | 354 kB  00:00:01
(6/11): nss-3.53.1-3.el7_9.x86_64.rpm                                                                      | 869 kB  00:00:02
(7/11): nss-sysinit-3.53.1-3.el7_9.x86_64.rpm                                                              |  65 kB  00:00:00
(8/11): nss-util-3.53.1-1.el7_9.x86_64.rpm                                                                 |  79 kB  00:00:00
(9/11): nss-tools-3.53.1-3.el7_9.x86_64.rpm                                                                | 535 kB  00:00:00
(10/11): curl-7.29.0-59.el7_9.1.x86_64.rpm                                                                 | 271 kB  00:00:04
(11/11): nss-pem-1.0.3-7.el7.x86_64.rpm                                                                    |  74 kB  00:00:06
----------------------------------------------------------------------------------------------------------------------------------
Total                                                                                             406 kB/s | 2.9 MB  00:00:07
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : nspr-4.25.0-2.el7_9.x86_64                                                                                    1/21
  Updating   : nss-util-3.53.1-1.el7_9.x86_64                                                                                2/21
  Updating   : nss-softokn-freebl-3.53.1-6.el7_9.x86_64                                                                      3/21
  Updating   : nss-softokn-3.53.1-6.el7_9.x86_64                                                                             4/21
  Updating   : nss-sysinit-3.53.1-3.el7_9.x86_64                                                                             5/21
  Updating   : nss-3.53.1-3.el7_9.x86_64                                                                                     6/21
  Installing : nss-pem-1.0.3-7.el7.x86_64                                                                                    7/21
  Updating   : libssh2-1.8.0-4.el7.x86_64                                                                                    8/21
  Updating   : libcurl-7.29.0-59.el7_9.1.x86_64                                                                              9/21
  Updating   : curl-7.29.0-59.el7_9.1.x86_64                                                                                10/21
  Updating   : nss-tools-3.53.1-3.el7_9.x86_64                                                                              11/21
  Cleanup    : nss-tools-3.16.2.3-5.el7.x86_64                                                                              12/21
  Cleanup    : curl-7.29.0-19.el7.x86_64                                                                                    13/21
  Cleanup    : libcurl-7.29.0-19.el7.x86_64                                                                                 14/21
  Cleanup    : nss-sysinit-3.16.2.3-5.el7.x86_64                                                                            15/21
  Cleanup    : nss-3.16.2.3-5.el7.x86_64                                                                                    16/21
  Cleanup    : nss-softokn-3.16.2.3-9.el7.x86_64                                                                            17/21
  Cleanup    : nss-util-3.16.2.3-2.el7.x86_64                                                                               18/21
  Cleanup    : nspr-4.10.6-3.el7.x86_64                                                                                     19/21
  Cleanup    : nss-softokn-freebl-3.16.2.3-9.el7.x86_64                                                                     20/21
  Cleanup    : libssh2-1.4.3-8.el7.x86_64                                                                                   21/21
  Verifying  : curl-7.29.0-59.el7_9.1.x86_64                                                                                 1/21
  Verifying  : nss-pem-1.0.3-7.el7.x86_64                                                                                    2/21
  Verifying  : libssh2-1.8.0-4.el7.x86_64                                                                                    3/21
  Verifying  : nss-tools-3.53.1-3.el7_9.x86_64                                                                               4/21
  Verifying  : nss-sysinit-3.53.1-3.el7_9.x86_64                                                                             5/21
  Verifying  : nss-3.53.1-3.el7_9.x86_64                                                                                     6/21
  Verifying  : nss-softokn-freebl-3.53.1-6.el7_9.x86_64                                                                      7/21
  Verifying  : nspr-4.25.0-2.el7_9.x86_64                                                                                    8/21
  Verifying  : libcurl-7.29.0-59.el7_9.1.x86_64                                                                              9/21
  Verifying  : nss-util-3.53.1-1.el7_9.x86_64                                                                               10/21
  Verifying  : nss-softokn-3.53.1-6.el7_9.x86_64                                                                            11/21
  Verifying  : libssh2-1.4.3-8.el7.x86_64                                                                                   12/21
  Verifying  : nss-softokn-freebl-3.16.2.3-9.el7.x86_64                                                                     13/21
  Verifying  : nss-util-3.16.2.3-2.el7.x86_64                                                                               14/21
  Verifying  : nss-sysinit-3.16.2.3-5.el7.x86_64                                                                            15/21
  Verifying  : nss-tools-3.16.2.3-5.el7.x86_64                                                                              16/21
  Verifying  : nss-softokn-3.16.2.3-9.el7.x86_64                                                                            17/21
  Verifying  : curl-7.29.0-19.el7.x86_64                                                                                    18/21
  Verifying  : nss-3.16.2.3-5.el7.x86_64                                                                                    19/21
  Verifying  : nspr-4.10.6-3.el7.x86_64                                                                                     20/21
  Verifying  : libcurl-7.29.0-19.el7.x86_64                                                                                 21/21

Dependency Installed:
  nss-pem.x86_64 0:1.0.3-7.el7

Updated:
  curl.x86_64 0:7.29.0-59.el7_9.1            libcurl.x86_64 0:7.29.0-59.el7_9.1            nss.x86_64 0:3.53.1-3.el7_9

Dependency Updated:
  libssh2.x86_64 0:1.8.0-4.el7                   nspr.x86_64 0:4.25.0-2.el7_9            nss-softokn.x86_64 0:3.53.1-6.el7_9
  nss-softokn-freebl.x86_64 0:3.53.1-6.el7_9     nss-sysinit.x86_64 0:3.53.1-3.el7_9     nss-tools.x86_64 0:3.53.1-3.el7_9
  nss-util.x86_64 0:3.53.1-1.el7_9

Complete!
[[email protected] ~]#

The error solved
[[email protected] ~]# rpm --import https://artifacts.elastic.co/GPG-KEY-elasticsearch
[[email protected] ~]#


Tidak ada komentar :

Posting Komentar